上次iPhone由4.3.1升級到4.3.2解決了電力的問題,Cydia的軟體是使用Aptbackup所備份的,升級版本後也直接從Aptbackup直接的還原,事後也一直都使用得好好的,直到最近有些套件要進行更新,卻發生了詭異的錯誤,不過忘記擷圖我就把問題解決了。這個錯誤不管在安裝、升級、移除軟體都會出現,彷彿整個軟體管理軟體是有問題的,但是Cydia的畫面並不能得知錯誤的訊息。

錯誤的訊息如下:(會出現兩次)
HTTP/1.0 403 This package is either paid or requires a paid package to function. If you paid: contact saurik@saurik.com for help. If not, purchase the original package.

乍看之下會覺得難道是破解軟體惹的禍?我一直鬼打牆的一直進入Cydia然後安裝移除軟體之類的,但是全部都失敗的,網路上我看也沒有比較恰當的解決方式,而且也不是某個套件會引發的問題,結論應該是套件版本與iOS版本衝突的問題,這是我遇到的狀況,不過解決同時也沒有把紀錄留下來,因為解決後我只想趕快查看iPhone是否正常。

那麼改怎麼樣處理這樣的問題,首先要先ssh進入你的iphone,使用apt-get這個指令。
哇哇3C日誌 綠色工廠2.0
通知!本文已經移轉到:Cydia無法安裝移除軟體時,該如何解決?,完整文章請到 哇哇3C日誌 收看唷!
更多資訊請參考:
Samsung Galaxy A7 開箱拍照評測
LIFAair 空氣清淨機,PM2.5、甲醛數據看的到!